New User
KPJgroup
Posts: 2
Registered: ‎08-21-2012
Accepted Solution
The "Buy Now" link does not work for eBook purchases from my PC now. Why?

For a week now, I've unsuccessfully been able to get a direct answer from BN to this question. One tech rep stated there is an "issue" with BN's eBook pages...another tech rep emailed me to install Nook Study Application (why would I do that when I use Nook Simple Touch)....I don't need or read e-textbooks. Another suggested that I install Nook for PC...I did that and nothing changed so I uninstalled that software. My recent eBook purchase was July 24th and things worked just fine up until now.

 

I even tried purchasing from another PC and the same issue.

 

I haven't tried purchasing books directly from Nook ST because I don't have WiFi at my home.

 

Can anyone out here help me??

View Entire Topic
Correspondent
ChipPM
Posts: 423
Registered: ‎12-22-2010
Answered

The website has done the same to me the same length of time. I believe there is or was a glitch on the website or their server.

 

I can now order online but no new purchases download to any of my Nooks. I have both e-inks and a Tablet and a Color. This was true all yesterday. I haven't tried yet today but I hope THAT is fixed!