Reply
Contributor
provotector
Posts: 5
Registered: ‎05-25-2013
0 Kudos

Connected but no internet problem.

First of all, I already readed all the another posts in this community about this issue and I can't find any working solution for me.

 

I have the famous problem thah shows the message: Connected but no internet.

 

My router is a TP-Link wit open WRT. I have no security and no password, no mac access control, DHCP on, I was reduced the speed of the lan from b+g+n+ to only g or b, I was turned off the Wifi multimedia, I choosed different channels, tried with an static IP... and nothing. I still without Internet access.

 

I tried manual update from 1.2.0 to 1.2.1, but the device is not updating. I put the file in the root, wait for a loooong time and nothing happens. The updating tool .zip is erased automatically, but not update applied.

 

Any solution please? Thanks.

Distinguished Bibliophile
Mercury_Glitch
Posts: 1,442
Registered: ‎06-07-2011
0 Kudos

Re: Connected but no internet problem.

From your post I'm guessing English is not your first language, did you buy your Nook from the UK?

 

I ask this because the UK Nook needs a different file to update than the US Nook. 

 

http://blog.empirion.co.uk/misc/updating-nook-simple-touch-nst-to-software-version-1-2-1-uk/

 

walks you through updating with the UK file, which is really the same as the US but the above provides the link for the UK update.

 

I suspect that you're having issues with the 1.2.0 firmware as 1.2.1 added european wifi channels.

 

 

The Wheel weaves as the Wheel wills, and we are only the thread of the Pattern.
Contributor
provotector
Posts: 5
Registered: ‎05-25-2013
0 Kudos

Re: Connected but no internet problem.

[ Edited ]

Thanks for your replies in both threads.

 

The system is now updated to V1.2.1 but still with the "connected but not to internet" problem.

 

-Hide ESSID. Unchecked.

-WMM mode. Unchecked.

-Security. WEP open system, also tryed with no encryption.

-Speed: 11Mbps.

-Mode: 82.11b, also tryed with g

-Mac filter: off

-DHCP: on IP: 192.168.1.208 

-Firewall: Input, Output, Fordward, open by default. No custom rules.

-Channels: Tryed 9,6,1 and auto.

 

All the devices connected to my wlan works fine, but not the nook. Also tryed to connect over other different wifi network and fails too.

 

How can I fix this issue?

 

EDIT: Rooted the device and internet works fine. :smileyvery-happy:

 

Contributor
provotector
Posts: 5
Registered: ‎05-25-2013
0 Kudos

Re: Connected but no internet problem.

[ Edited ]

Its clear that the internet connection problem is a software issue, not a problem with the access points. Now I have internet working fine with Wifi n, and WPA2-TIKP securyty!

 

Awesome... very very awesome :smileyvery-happy: