Since 1997, you’ve been coming to BarnesandNoble.com to discuss everything from Stephen King to writing to Harry Potter. You’ve made our site more than a place to discover your next book: you’ve made it a community. But like all things internet, BN.com is growing and changing. We've said goodbye to our community message boards—but that doesn’t mean we won’t still be a place for adventurous readers to connect and discover.

Now, you can explore the most exciting new titles (and remember the classics) at the Barnes & Noble Book Blog. Check out conversations with authors like Jeff VanderMeer and Gary Shteyngart at the B&N Review, and browse write-ups of the best in literary fiction. Come to our Facebook page to weigh in on what it means to be a book nerd. Browse digital deals on the NOOK blog, tweet about books with us,or self-publish your latest novella with NOOK Press. And for those of you looking for support for your NOOK, the NOOK Support Forums will still be here.

We will continue to provide you with books that make you turn pages well past midnight, discover new worlds, and reunite with old friends. And we hope that you’ll continue to tell us how you’re doing, what you’re reading, and what books mean to you.

Reply
Reader
LonelyDreamer
Posts: 1
Registered: ‎01-05-2010
0 Kudos

My Nook won't load a book already downloaded

My Nook won't load a book.  It just stays on the Loading screen or Opening Book screen.  Is there a way to re-download the book?

Inspired Bibliophile
FrogAlum
Posts: 3,425
Registered: ‎12-25-2009
0 Kudos

Re: My Nook won't load a book already downloaded

Archive the book, then unarchive it...  It should download a new copy.  If that doesn't work you need to call Customer Service at 1-800-THE-BOOK (1-800-843-2665), option 2 for Digital Support.

New User
MrFlufferman
Posts: 3
Registered: ‎01-02-2012
0 Kudos

Re: My Nook won't load a book already downloaded

try turning it off and then back on

New User
JessB
Posts: 1
Registered: ‎02-08-2014
0 Kudos

Re: My Nook won't load a book already downloaded

Thanks very much tried the archive and I archive and it worked perfectly now!